30

As you noticed, from the man vncserver: -kill :display# This kills a VNC desktop previously started with vncserver. It does this by killing the Xvnc process, whose process ID is stored in the file "$HOME/.vnc/host:display#.pid". It actually ignores anything preceding a ":" in its argument. This can be useful so you ...


13

I always use ps -ef | grep vnc, then pick out the parts I need from that.


6

Easy steps to confgure VNC: Create a user (e.g., user1). Edit the /etc/sysconfig/vncservers file. Enter the below entry in the file. VNCSERVERS="2:user1" VNCSERVERARGS[2]="-geometry 800x600 -nolisten tcp -nohttpd -localhost" Login through user (user1). Execute ls -la in the user's home directory and check whether the .vnc directory exists. If not, run ...


4

For the more tech savvy installing a "Gaming Anywhere" server and client may be useful: http://www.gaminganywhere.org/index.html I¡d suggest to take a look at the performance experiment they did; the figures are quite impressive except for network load that is sometimes very slightly over the already deceased OnLive or StreamMyGame. http://www....


4

Use this command rpm -qa | grep tigervnc-server


4

I used TightVNC a lot at my last job, and most VNC solutions are based off of the open VNC standard. With the way VNC works and what you want to do, the only way to get this done is to set the geometry as you stated to support a large horizontal resolution. You can't separate the monitors because VNC has no concept of a 'separate' monitor. Furthermore, the ...


3

Solved it myself. I just had to change the ownership of the /run/user/1000 to my VNC user i.e. vnc. Below is the command to do it: sudo chown -R vnc:vnc 1000/ This solved the problem. Hope that helps someone! Thanks


3

Here how to add a firewall exception (you'll need to open ports 5900 and 5800). Linux is not my strong side, so I hope this picture helps...


3

On my Ubuntu server, it wasn't working either with the -randr parameter, but it works great by using several times the -geometry parameter. Give it a try. So you would enter: vncserver -geometry 1600x1200 -geometry 1440x900 -geometry 1024x768 And after, you use the xrandr command to change the resolution.


3

If you need to change the setting without restarting VNC server, I had good results with: vncconfig -set RandR="1024x768,1600x900" and then using xrandr to change resolution as fgregg suggested: xrandr -s 1024x768 xrandr -s 1600x900


2

You need a server running somewhere to connect to. But you don't need a server on your machine to use the view. Unless you really know what you are doing, you don't want to connect to a server running on your own machine. Connecting can cause problems with updating the view if the view contains the viewer. It can result in feedback loops where the view ...


2

You may be able to use socat to forward a UNIX domain socket to a TCP port. It is very flexible and lets you forward just about any source to any target.


2

You could do reverse ssh tunneling. Your client connects to your ssh server specifying something like ssh -R 5900:localhost:5900 your-pc. You can then connect to localhost:5900 with your vnc client and it gets tunneled back to the client (which obviously has to have a VNC server running on his computer).


2

There's a significant difference between using ssh -X or the VNC system. With VNC you get a visual copy of the desktop on the remote system at that moment the VNC server was started. With ss -X you start a new X-session; it also requires a X-Windows system on the local computer. Because a Mac is basically a *nix system, this shouldn't be a problem. So it ...


2

To find out from what package (and version) a file comes, you can do rpm -qf /usr/bin/vncserver, see the manual for rpm(1). But note that RHEL (as do all enterprisey distributions) selects a base version, and keep that one whatever may come during the RHEL 5.x series in this particular case. The base software is patched with backports for new features (where ...


2

Why is the process killed? When you connect, your default bash gets started. Now as you start a process, they are sub process of bash. If the connection gets closed, bash and all it's sub processes are being terminated. Solution: use screen. Run screen and start your build process. If you have a disconnect, everything run after screen will continue. If you ...


2

No. Neither TightVNC nor UltraVNC can use RDP, as per this comparison chart from Wikipedia. Sort on the second column ('Protocols') of the first chart to see the apps which do use RDP.


2

I have found this link which explains that there have been some changes to systemd, so this is more than likely where the issue is coming from. https://community.oracle.com/thread/4286364 I have removed the line referring to the pid from my vncserver@:x file and no longer get an error reporting, although the pid is still reporting an error. Hopefully there ...


1

Job for vncserver@:7.service failed. See 'systemctl status vncserver@:7.service' and 'journalctl -xn' for details. Delete this folder: rm -r /tmp/.X11-unix/ Its work for me. Reference: vncserver refuses to start How To Install and Configure VNC Remote Access for the GNOME Desktop on CentOS 7


1

First you should try to access it from inside your local network, if it works (probrably will) it means it is something with your router. Did you created the VirtualServer correctly? As far as i know the connections port and the java viewer port shall be different from each other. The java port is used to provide a java viewer client on browsers. Try it


1

You don't mention a firewall, but I'm assuming there is one in this problem. Default configuration for your average firewall is to allow all OUTBOUND traffic. Most GoToMyPC, TeamViewer, etc. clients work by establishing the connection outbound from the client, and the firewall allows the return traffic. I'm not seeing the specifics on SiteKiosk. If you are ...


1

I tried the answer above and it didn't work for me. It gave me an error message as in this question: Killing VNC Process Manually So I had to kill them manually. I tried kill -9, and then I couldn't log in with rdp anymore. I got xrdp_mm_process_login_response: login failed when I tried to log in. The answer was found here: http://linuxtoolkit.blogspot.com/...


1

I had a similar issue. This gave me the same error: vncconfig -set RandR="1855x1055" SOLUTION: open VNC server 'Options' dialog go to 'Expert' tab find the 'RandR' parameter and set the value as needed! See Options screen After clicking 'Apply' you'll be able to resize screen with xrandr -s 1855x1055 That worked for me, I hope it will help!


1

You will need to do: vi /etc/sysconfig/iptables Then, you will find a file as follows: # Firewall configuration written by system-config-firewall # Manual customization of this file is not recommended. *filter :INPUT ACCEPT [0:0] :FORWARD ACCEPT [0:0] :OUTPUT ACCEPT [0:0] -A INPUT -m state --state ESTABLISHED,RELATED -j ACCEPT -A INPUT -p icmp -j ACCEPT -...


1

Seems that the person giving previously assistance to your friend use teamviewer, not vnc.


1

With TigerVNC Windows VNC client (viewer) auto resolution works out of the box. No need to set anything anywhere, on the client or on the server. When you first connect to your server, the resolution is set to whatever is preset on the server side but you can easily change it just by resizing the client window; to any resolution, any crazy, non-standard, ad-...


1

So I have seen the same question asked on 5 different stackexchange sites, and all the answers say to just remove the hotkey, which does work, but isn't the root of the problem (at least it wasn't for me). The real problem is that the windows super key is not mapped correctly, as is described here: i3 ignores mod4 (windows key) when in VNC session ...


1

try restarting messagebus service. service messagebus restart


1

For linux: $ apt-cache show xpra .... Description-en: tool to detach/reattach running X programs Xpra gives you the functionality of GNU Screen for X applications. . It allows the user to view remote X applications on their local machine, and disconnect and reconnect from the remote machine without losing the state of the running applications. . ...


1

It definitely means something else in using the port. Change it to 5801, 5901, etc. and the server will start listening.


Only top voted, non community-wiki answers of a minimum length are eligible